Summary
Traffic Engineering helps network operators use their network more efficiently.
While some routers support basic TE functions, a Controller or Path Computation Element (PCE) makes SR-TE much better. The PCE helps the routers avoid congested links; build active/backup path without shared links and improves general network performance and stability.
How SR-TE with PCE works
Routers export the IGP topology into BGP-LS [RFC9552], [RFC9085], and a BGP-LS speaker advertises the topology to the PCE.
The PCE computes traffic engineering policies, and advertises it to the routers using one of the methods shown below:

A good PCE brings many benefits to a Segment Routing network, such as:
Bandwidth reservations
Since SR-TE is stateless and there is no LSP signaling like in RSVP-TE, an external controller with a centralized bandwidth database is required to keep track of bandwidth reservations.
Also centralizing the bandwidth database brings makes bandwidth reservations faster and more optimal.
Disjoint paths
Some critical services require the active and backup paths to avoid shares links or SRLG. A centralized PCE helps to satisfy this requirement, as shown on the diagram:

Vendor independence
Many SR implementations can perform most ISP router functions, at a fraction of a cost of equipment from legacy vendors. But advanced SR-TE is not widely supported, which allows big vendors to sell it as a premium feature.
A good PCE removes this barrier and enables a full SR-TE feature set with any equipment, including whitebox and open source routing stacks.
About Traffic Dictator
Traffic Dictator is a PCE designed to do routing, and do it well. TD calculates optimal paths in a Segment Routing network, programs SR-TE policies and provides topology visualization.
Unlike most competing products, TD does not attempt to replace network management or automation software, but complements it by providing API for integration into the operator’s existing systems.
Simplicity
No esoteric YAML configs or cluttered GUI with hundreds of options.
Traffic Dictator provides an industry-standard CLI, intuitively understood by any network engineer; and a minimalistic Web UI with topology visualization and the capability of configuring SR-TE policies.
Automation with mesh templates
A common operational problem with Traffic Engineering is the complexity of creating and maintaining the configurations, which can grow very large. Network automation tools can help with managing SR-TE configs to some extent, but introduce an extra layer of complexity.
Mesh templates are a foundation for scalable SR-TE. The operator configures the service intent, Traffic Dictator generates policies to serve it. Policies are automatically added or removed when the intent changes or new routers are provisioned, no operational involvement is required.
Thanks to BGP-SRTE [RFC9830], there is no need for PCE to maintain a BGP session with each router. Instead, an existing BGP route reflector infrastructure is reused to distribute policies from the PCE to the routers. BGP also makes it easy to design PCE redundancy.

Segment list generation algorithm
A unique challenge with SR-TE is calculating a segment list to steer traffic over the chosen path. While there is no standard for it and every implementation takes a different approach, the algorithm in Traffic Dictator generates the most optimal segment lists. It natively supports ECMP, Anycast SID, Egress Peer Engineering, Multi-domain LSP and has a number of other optimizations.
While SR-TE and TI-LFA coexistence is a complex topic with no universal solution, the segment lists generated by Traffic Dictator are more TI-LFA-friendly than other implementations, providing better coverage and faster convergence.
Open Networking
While TD is vendor-independent and works with any SR-capable router, it adds the most value when combined with Open Networking platforms, by augmenting them with a full SR-TE functionality.
We have designed and validated SR-TE solutions with IP Infusion and VyOS networks; leaders in their respective markets of Disaggregated and Virtual networking.
Conclusion
Traffic Engineering with Segment Routing helps network operators to balance traffic, improve network performance and resilience, automate operations and reduce OPEX.
Traffic Dictator is a vendor-independent PCE that enables advanced SR-TE even on the most basic SR implementations.
